PHP is one of the most widely used open-source server-side scripting languages. It’s highly popular because it is free software, which you can use to build interactive websites like community web portals, web stores or e-teaching websites as opposed to static HTML websites. A PHP module must be enabled on the server where a PHP website is hosted so that its source code can be ‘decoded’. As there aren’t any license taxes for this type of module and the language itself provides infinite options for the web-based apps that you develop, there are 100s of millions of PHP-powered websites. On top of that, there are loads of PHP scripts, which you can use for your sites without needing to possess any coding skills. Given the fact that there’re a handful of versions of PHP, you have to confirm if the same exact version that you used whilst creating your website is enabled on the server too.
PHP 4, PHP 5 and PHP 7 Support in Shared Hosting
In case you get a shared hosting plan from us, you won’t ever have to speculate over whether your sites are compatible with the web hosting platform, since we support several PHP versions for your convenience’s sake. The Hepsia Control Panel will allow you to pick PHP 4, PHP 5 and PHP 7 with just one single mouse click and in case you want to change the version, the update will be applied right away. In this way, many years of work on websites created with an older version will not be lost. Our hosting platform will even permit you to use a different PHP version for each domain name hosted in your account, which goes to say that you can run newer and older scripts at the same time. Most hosting companies on the marketplace offer support for one, sometimes for two PHP versions. In stark contrast with them, we strongly trust that you should be the one to select the version that your own websites will be using.
PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting
We are firm in our conviction that years spent developing a site should not be in vain, so in case you buy a semi-dedicated server from us, you’ll be able to run any script, regardless of whether it is new or old. In stark contrast to a lot of hosting suppliers, we support a number of different versions of PHP on our revolutionary cloud web hosting platform – 4, 5 and 7. You will not only have the ability to enable the version that you need via your Hepsia hosting Control Panel, but you will also have the possibility to choose a different version for each individual website. This can be done simply by uploading an .htaccess file to the root folder of the given site. You can change the version not only for a single site, but also for the entire account and the new settings will take effect in less than several minutes. With our hosting services, you can be sure that you will never have any website incompatibility challenges.